OS MELHORES VÍDEOS

 

Pesquisar

segunda-feira, 27 de maio de 2013

Converter datas armazenadas como texto em datas.

    Ocasionalmente, as datas são formatadas e armazenadas nas células como texto. Por exemplo, talvez você tenha digitado uma data em uma célula que estava formatada como texto, ou a data pode ter sido importada ou colada de uma fonte de dados externa como texto.





    As datas formatadas como texto são alinhadas à esquerda e não à direita em uma célula. Além disso, se a Verificação de Erros estiver ativada, as datas de texto com ano de dois dígitos também poderão ser marcadas com um indicador de erro Célula com um problema de fórmula

    Como a Verificação de Erros no Excel pode identificar datas formatadas como texto com anos de dois dígitos, é possível usar as opções de correção automática para convertê-las em datas formatadas como datas. Você pode usar a função DATAVALOR para converter a maioria dos tipos de datas formatadas como texto em datas.

Converter datas de texto usando a Verificação de Erros

    Se você importar dados de outra fonte no Excel ou se digitar datas com anos de dois dígitos em células anteriormente formatadas como texto, talvez veja um pequeno triângulo verde no canto superior esquerdo da célula. Esse indicador de erro informa que a data está armazenada como texto, conforme mostra este exemplo.

Células com indicador de erro verde no canto superior esquerdo

Use o procedimento a seguir para converter de volta a data formatada como texto em uma data regular.

  1. Na planilha, selecione qualquer célula única ou intervalo de células adjacentes que tenha um indicador de erro no canto superior esquerdo.
  1. Próximo à célula ou intervalo de células selecionado, clique no botão de erro exibido.
Botão de erro
  1. No menu, clique em Converter XX em 20XX ou Converter XX em 19XX. (Para simplesmente se livrar do indicador de erro sem converter o número, clique em Ignorar Erro.)
Comandos para converter datas

Esta ação converte as datas de texto com anos de dois dígitos em datas padrão com anos de quatro dígitos.


Datas convertidas

Depois de converter as células a partir das datas formatadas como texto, você pode alterar a maneira como as datas são exibidas nas células aplicando formatação de datas.



Converter datas de texto utilizando a função DATAVALOR

    Para converter uma data de texto em uma célula para um número de série, utilize a função DATAVALOR. Em seguida, copie a fórmula, selecione as células que contém as datas de texto e utilize Colar Especial para aplicar um formato de data a elas.
  1. Selecione uma célula em branco e verifique se o formato de número é Geral.
  1. Na célula em branco:
    1. Digite =DATAVALOR (
    2. Clique na célula que contém a data formatada como texto que deseja converter.
    3. Digite)
    4. Pressione Enter.
A função DATAVALOR retorna o número de série da data que está representada pela data de texto.


  1. Para copiar a fórmula de conversão em um intervalo de células contíguas, selecione a célula na qual digitou a fórmula e, em seguida, arraste a alça de preenchimento imagem da alça de preenchimento por um intervalo de células vazias que correspondem em tamanho ao intervalo de células que contêm datas como texto.
Depois de arrastar a alça de preenchimento, você deve ter um intervalo de células com números de série que correspondem ao intervalo de célula que contém datas como texto.
  1. Selecione a célula ou o intervalo de células que contém os números de série e pressione Ctrl+C ou, na guia Página Inicial, no grupo Área de Transferência, clique em Copiar.
Imagem da Faixa de opções do Excel
  1. Selecione a célula ou o intervalo de células que contém as datas como texto e, em seguida, na guia Página Inicial, no grupo Área de Transferência, clique na seta abaixo de Colar e em Colar Especial.
  2. Na caixa de diálogo Colar Especial, em Colar, selecione Valores e clique em OK.
  1. Na guia Página Inicial, clique no Iniciador de Caixa de Diálogo ao lado de Número.
Imagem da Faixa de Opções
  1. Na caixa Categoria, clique em Data e clique no formato de data desejado na lista Tipo.
  2. Para excluir os números de série depois que todas as datas forem convertidas com êxito, selecione as células que os contêm e, em seguida, pressione a tecla Delete.

Desativar a Verificação de Erros

    Com a Verificação de Erros ativada no Excel, você verá um indicador de erro se digitar uma data com um ano de dois dígitos em uma célula que tem formatação de texto aplicada nela. Se preferir, desative esse recurso Verificação de Erros.
  1. Clique na guia Arquivo.
  2. Clique em Opções.
  3. Na caixa de diálogo Opções do Excel, clique na categoria Fórmulas.
  4. Em Regras de Verificação de Erros, desmarque a caixa de seleção Células contendo anos representadas como 2 dígitos.
  5. Clique em OK.

4 comentários:

  1. Como transformar um valor em texto?
    Quero digitar o valor 1 e na celula ao lado apareça texto "meu", ou digitar o valor 2 e aprecer texto "seu"

    ResponderExcluir
  2. Anônimo26 de junho de 2014 06:05, tente esta fórmula

    =SE(A1=1;"meu";SE(A1=2;"seu"))

    Att. Marco

    ResponderExcluir
  3. Anônimo de 26 de junho de 2014 06:05... tente esta fórmula

    =SE(A1=1;"meu";SE(A1=2;"seu"))

    Att. Marco

    ResponderExcluir
  4. Alguém pode me ajudar?
    tenho célula A1 com 28 Days +12:51:48
    Tenho celula A2 com 30 Days + 23:59:59
    Como faço para saber o tempo de A2 - A1 ??
    Nessa conversão...

    ResponderExcluir