OS MELHORES VÍDEOS

 

Pesquisar

domingo, 31 de março de 2013

Microsoft Excel – Criando um gráfico condicional

O que é um gráfico condicional? É um gráfico que muda de cor de acordo com um critério que você especificar.





    Por exemplo, você tem 3 estágios em uma linha de produção: Produção Baixa, Produção Esperada e Super Produção. Você gostaria de colocar estes estágios em três cores diferentes em um gráfico de colunas, com apenas 1 coluna e não três como normalmente seria…
Nosso problema é esse:
Gráfico condicional

Planilha salva? Vamos lá:
    Crie três colunas onde vocês irão separar os valores: Produção Baixa, Produção Esperada e Super Produção. Você já sabe qual o critério de cada uma, então, precisamos dividir os valores de produção em suas colunas correspondentes:
Gráfico Condicional - Parte 2


    Para Produção Baixa vamos fazer a seguinte função: =SE(B5<100000;B5;0), onde o valor de B5 aparecerá na coluna caso ele seja menor que 100.000 senão aparecerá 0.
    Para Produção Esperada vamos fazer a seguinte função:=SE(E(B5>=100000;B5<=400000);B5;0), onde o valor de B5 aparecerá na coluna caso ele seja maior ou igual a 100.000 E menor ou igual a 400.000 senão aparecerá 0.
    Para Super Produção vamos fazer a seguinte função:=SE(B5>400000;B5;0), onde o valor de B5 aparecerá na coluna caso ele seja maior que 400.000 senão aparecerá 0.
Não esqueça de arrastar as fórmulas para baixo!
Você terá o seguinte resultado:
Gráfico Condicional - Parte 3

    A dica a seguir serve apenas para Office 2007 e 2010, galera mais velhinha, mande-me um e-mail que darei um apoio. Clique em uma área vazia da planilha e pressione ALT + F1, você terá um gráfico em branco.
Gráfico condicional - parte 4


    Com o gráfico vazio inserido, vamos brincar um pouco! Selecione desde Super Produção até o último valor de sua coluna, copie e cole dentro do gráfico. Isso mesmo! Vai, tenta!
Agora clique na coluna azul que apareceu e lá no topo localize Ferramentas de Gráfico, Formatar.
Ferramentas de Gráfico, Formatar


    Localize o botão Preenchimento da Forma e escolha a cor Verde, você pode também no grupo Estilos da Forma escolher um modelo verde pronto pré-configurado.
Seu gráfico ficará assim:
Gráfico Condicional


    Agora repita o processo de copiar e colar para as outras duas colunas. Não esqueça de personalizar, ok? Lembre-se Produção Baixa em Vermelho,Produção Esperada em Azul e Super Produção em Verde.
Teremos este resultado ao final desta etapa:
Gráfico condicional - Quase Ok


    Agora falta pouco, vamos aos ajustes finais:
Primeiro, iremos alterar os números referentes aos meses para o nome dos meses:
    Clique no gráfico, vá em Ferramentas de Gráfico, Design e clique no botãoSelecionar Dados. Em Rótulos do Eixo Horizontal (categorias) você deve clicar no botão Editar e depois selecione os meses das células A5 até A16pressione Ok e depois Ok novamente e pronto, você terá este resultado:
Agora falta pouco para nosso Gráfico Condicional


    Vamos aos “ finalmente”, clique com o botão direito sobre qualquer coluna deste gráfico e escolha Formatar Série de Dados… Na janela que se abre, simplesmente faça os seguintes ajustes:
Sobreposição de Séries: 100% – Isso fará com que as colunas fiquem uma sobre a outra, dando a impressão da troca de cor.
Largura do Espaçamento: Cerca de 20% – Isso fará com que as colunas fiquem mais largas dando um efeito muito interessante.
Este é nosso resultado final:
Gráfico Condicional 3 condições - Completo


    Agora, experimente alterar o valor da produção em qualquer um dos meses para ver as colunas “mudando” de cor, e impressionando muita gente.
Malandramente, coloque o gráfico posicionado exatamente sobre a área onde você dividiu a informação. Ninguém precisa saber que tem um segredo ali atrás não é?
Solução - Gráfico Condicional


    Lembro que com esta técnica, você pode criar gráficos condicionais com o número de cores que quiser. Tudo dependerá de quantas colunas de condições você criará.


Assista o Vídeo

Um comentário:

  1. Bom dia, gostei muito dessa dica e já utilizo atualmente no meu trabalho. Mas surgiu um problema quando eu preciso colocar um campo de filtro (Eu uso com gráfico dinâmico): O problema surge quando eu preciso colocar mais de um item no campo de filtro, no exemplo dado seria um "Produto B" por exemplo. Gostaria de saber se há a possibilidade de resolver este problema. Muito obrigado.

    ResponderExcluir