OS MELHORES VÍDEOS

 

Pesquisar

domingo, 28 de outubro de 2012

Encontrar o vencedor para uma concorrência do menor preço

    Hoje vou ensinar uma dica super rápida e básica com o uso de algumas fórmulas do Excel. Apesar de ser bem fácil de utilizar não permite-nos associar ao uso banal ou simplório. Em muitos casos precisamos identificar numa tabela gigantesca de dados um determinado valor que seria extremamente desgastante e demorado se o fizéssemos manualmente, procurando item por item. Imaginem isso!

    Vamos aprender mais uma alternativa de pesquisa dentro de uma planilha. O exemplo que vamos trabalhar faz uma junção de funções e tem como temática a identificação do menor valor (preço) numa tabela que possui os concorrentes de um certame para a oferta de alguns produtos fictícios.




Como achar quem ofertou o menor preço?

Vamos criar uma tabela como está da imagem abaixo.













Para encontrarmos as empresas que oferecem os menores preços, começando pelo Produto A, na célula C10, digitar a seguinte formula:
=INDIRETO(ENDEREÇO(CORRESP((MÍNIMO(C3:C7));C3:C7;0)+LIN(C3:C7)-1;2))
assim vamos ter como resultado a EMPRESA 03, para o Produto A

Vamos agora encontrar qual empresa ofertou no menor preço para o Produto B, para isso é só copiar e colar a formula da célula C10 e para o Produto C é o mesmo processo.

Vamos agora utilizar a função Procv para encontrar os preços das respectivas empresas.
Na célula C11, digitar a seguinte formula:
=PROCV(C10;$B$3:$E$7;2;0)
Agora é só clicar na alça de preenchimento para preencher as células D11 e E11.



Nosso resultado final será...



7 comentários:

  1. Muito bom. Utilizando a função desloc + corresp também chega ao mesmo resultado. No caso em empresa coloquei =DESLOC(B1;CORRESP(C11;C3:C7;0);0;1;1) e em preço utilizei a função MÍNIMO para cada produto.

    ResponderExcluir
  2. Gostaria de colocar os itens na vertical e as empresas na horizontal,pois, trabalho com gêneros alimentícios quando faço a cotação dos produtos

    ResponderExcluir
  3. Gostaria de baixar esse modelo de tabela...eh exatamente o que eu preciso.
    Alguem pode me ajudar.

    ResponderExcluir
  4. Na minha planilha empresas e preços estão na vertical, como faço?

    ResponderExcluir
    Respostas
    1. Tambem gostaria de saber... minha planilha está na mesma situação na vertical.

      Excluir
    2. Bom dia amigo.. estou na mesma solução q vc.. caso vc tenha obtido solução, vc poderia compartilhar essa informação. Grato . wiltonpedro@hotmail.com

      Excluir
  5. gostaria de saber quando houver valores iguais (empate).

    ResponderExcluir